Matematické Fórum

Nevíte-li si rady s jakýmkoliv matematickým problémem, toto místo je pro vás jako dělané.

Nástěnka
!! 17.06.2018 (Jel.) Khanova škola zve nadšence ke spolupráci na překladech návodů pro učitele a rodiče.
! 04.11.2016 (Jel.) Čtete, prosím, před vložení dotazu, děkuji!
17.01.2016 (Jel.) Rok 2016 s novými a novějšími krystaly od kolegy Pavla!
17.01.2016 (Jel.) Nabídka knih z oborů matematiky, fyziky, chemie
23.10.2013 (Jel.) Zkuste před zadáním dotazu použít některý z online-nástrojů, konzultovat použití můžete v sekci CAS.

Nejste přihlášen(a). Přihlásit

#1 02. 10. 2018 09:16

Bastions
Příspěvky: 50
Pozice: Študent
Reputace:   
 

Excel - podmienky

Dobrý deň,

mám problém s takouto úlohou:

Pomocou grafu mám zobraziť najkratšiu cestu z bodu A do bodu B v sieti 5*3 (pohyb len vertikálne alebo horizontálne, nie diagonálne), pričom 5 je hodnota osi x a 3 je hodnota osi y. Táto cesta má byť náhodne generovaná, pričom musí vždy skončiť v bode [5,3].

Začal som stĺpčekom, v ktorom generujem náhodne nuly a jednotky pomocou funkcie RANDBETWEEN. Môj vzorec:

=RANDBETWEEN(0;1)

Následne výsledné hodnoty zadávam do dvoch vedľajších stĺpčekov, buď do stĺpca x alebo y pomocou tohto vzorca:

pre x
=KDYŽ(A3=1;1;0)

pre y
=KDYŽ(A3=0;1;0)

Tu nastáva prvý problém - ako by sa dalo zabezpečiť aby v náhodnom poradí vygeneroval Excel päť jednotiek a tri nuly?
Nakoľko som na to neprišiel, postupoval som takto:

Hodnoty zo stĺpcov následne pripočítavam do stĺpcov pravo(pre x) a hore(pre y), čím dostávam usporiadané dvojice.
A tu nastáva druhý problém. Totiž nie vždy padne potrebný počet jednotiek a núl, preto často dostávam na konci stĺpcov dvojice typu [7,3], [4,5], atď..

Snažil som sa to vyriešiť takouto podmienkou:

=KDYŽ(A(E2=3;D2<5);D2+1;D2+B3)

Ak hodnota hore =3 a hodnota pravo < 5, potom ku hodnote pravo pripočítaj 1, inak pripočítaj ku pravo hodnotu x.

Pre stĺpec hore mám takúto podmienku:

=KDYŽ(A(D2=5;E2<3);E2+1;E2+C3)

Bohužiaľ vzorec nefunguje.

Viete mi s tým prosím pomôcť?

Basti.

http://forum.matematika.cz/upload3/img/2018-10/64502_graf1.png

http://forum.matematika.cz/upload3/img/2018-10/64531_graf3.png

Offline

 

#2 02. 10. 2018 09:27

Stýv
Vrchní cenzor
Místo: Q
Příspěvky: 5204
Reputace:   195 
Web
 

Re: Excel - podmienky

Když potřebuješ vygenerovat n čísel a z toho m jedniček, generuj číslo od 1 do n a pokud je menší nebo rovno m, tak z něj udělej jedničku, jinak nulu. Podle toho co vyjde, upravíš m a n a pokračuješ. Tímhle způsobem ti vyjdou všechny cesty se stejnou pravděpodobností.

Offline

 

#3 02. 10. 2018 15:45

Bastions
Příspěvky: 50
Pozice: Študent
Reputace:   
 

Re: Excel - podmienky

Ja pri mojom prvom postupe používam RANDBETWEEN v každom riadku. V prípade, ktorý navrhujete by to vyzeralo tak, že generujem čísla od 1 do 8, teda ak je vygenerované číslo menšie alebo rovné 5 tak zapíš jednotku, inak nulu. Lenže ak to spravím rovnakým spôsobom tak opäť nemám zabezpečené, že vygenerované čísla sa nebudú opakovať. Ako ste teda mysleli Vaše riešenie? Dokáže excel z daného intervalu postupne generovať čísla, s tým, že sa nebudú opakovať?

Offline

 

#4 02. 10. 2018 16:21

Stýv
Vrchní cenzor
Místo: Q
Příspěvky: 5204
Reputace:   195 
Web
 

Re: Excel - podmienky

Stýv napsal(a):

Podle toho co vyjde, upravíš m a n a pokračuješ.

Offline

 

#5 02. 10. 2018 18:44

Bastions
Příspěvky: 50
Pozice: Študent
Reputace:   
 

Re: Excel - podmienky

Ale ako upravím to m a n?

Čísla <= 5 budú jednotky, 6,7,8 budú potom nuly.
Mám interval (1;8), v prvom riadku dostanem číslo 6, čiže to bude nula, ale ako v ďalšom riadku zabezpečím aby som znovu nedostal 6? Ako to mám upraviť? Tam je totiž kameň úrazu. (Stále sa držím funkcie RANDBETWEEN a intervalu).

Offline

 

#6 02. 10. 2018 19:59

Stýv
Vrchní cenzor
Místo: Q
Příspěvky: 5204
Reputace:   195 
Web
 

Re: Excel - podmienky

V dalším řádku budeš generovat čísla z intervalu 1-7 a rozhodovat se podle toho, jestli je to <=5-(počet jedniček v řádcích výše). Klidně můžeš zase dostat 6, to ničemu nevadí.

Offline

 

#7 02. 10. 2018 20:03

Bastions
Příspěvky: 50
Pozice: Študent
Reputace:   
 

Re: Excel - podmienky

Čiže v každom ďalšom riadku uberiem z intervalu?
(1;8)
(1;7)
(1;6)
atď.?

Offline

 

#8 02. 10. 2018 20:34

Stýv
Vrchní cenzor
Místo: Q
Příspěvky: 5204
Reputace:   195 
Web
 

Re: Excel - podmienky

ano

Offline

 

Zápatí

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson